mysql密码输入正确进不去(如果mysql密码登陆不了怎么办)

本文目录
- 如果mysql密码登陆不了怎么办
- 密码正确Navicat连接mysql报1045
- windows下登录mysql数据库密码正确为什么登录不进去
- 用户名密码都正确,就是连不上mysql是怎么回事
- MyEclipse中连接MySQL出现的错误怎么解决呀,急求谢谢
- mysql怎么登录不了
- MySQL密码正确却无法本地登录怎么办
- mysql突然登录不了
如果mysql密码登陆不了怎么办
MySQL有时候忘记了root密码是一件伤感的事。这里提供Windows 和 Linux 下的密码重置方法。
Windows:
1.以系统管理员身份登陆系统。
2.打开cmd-----net start 查看mysql是否启动。启动的话就停州宏旦止net stop mysql.
3.我的mysql安装在d:\usr\local\mysql4\bin下。
4.跳过权限检查启动mysql.
d:\usr\local\mysql\bin\mysqld-nt --skip-grant-tables
5.重新打开cmd。进到d:\usr\local\mysql4\bin下:
d:\usr\local\mysql\bin\mysqladmin -u root flush-privileges password "newpassword"
d:\usr\local\mysql\bin\mysqladmin -u root -p shutdown 这句提示你重新输密码。
6.在cmd里net start mysql
7.搞定了。
Linux:
MySQL root密码的恢复方法之一
如果忘记了MySQL root密码,可以用以下方法重新设置:
1.KILL掉系统里的MySQL进程;
killall -TERM MySQLd
2.用以下命册扰令启动MySQL,以不检查权限的方式启动;
safe_MySQLd --skip-grant-tables &
3.然后用空密码方式绝樱使用root用户登录 MySQL;
MySQL -u root
4.修改root用户的密码;
MySQL》 update MySQL.user set password=PASSWORD(’新密码’) where User=’root’;
MySQL》 flush privileges;
MySQL》 quit
重新启动MySQL,就可以使用新密码登录了。
密码正确Navicat连接mysql报1045
方法/步骤
MySQL服务器正在运行,停止它。 如果是作为Windows服务运行的服务器,进入计算机管理---》服务和应用程序------》服务 如果服务器不是作为服务而运行的,可能需要使用任务管理器来强制停止它。
请点击输入图片描述
请点击输入图片描述
创建1个文本文件(此处命名为mysql-init.txt),并将下述命令置于单一行中: SET PASSWORD FOR ’root’@’localhost’ = PASSWORD(’MyNewPassword’);
请点击输入图片描述
(注意将我们创建的文件导入到 MySql安装目录下的bin目录下 D:\progame\bin) progame为我自己MySql目录,注意不要导错【是自己安装目录下的sql】
请点击输入图片描述
在服务器启动时,执行由“--init-file”选项(作用:在启动时从指定的文件中读取SQL命令)命名的文件的内容,更改根用户密码。当服务器成功启动后,应删除我们导入的mysql-init.txt文件
最后停止MySQL服务器,然后在重启它。【注意以自动方式运行服务器,应从Windows服务窗口启动它。如果以手动方式启动了服务器,能够像正常情形下一样使用命令。】然后发现连接上数据库了
请点击输入图片描述
windows下登录mysql数据库密码正确为什么登录不进去
不是说账号正确就其他就能访问了,MySQL分3层,你在连接层,会判断你的账号是否合法,以及是否安全!怎么判断呢,你使用客户端的账号,是否已经存在mysql.user表下面,user和host同时匹配才可以连接上哦!
select user,host from mysql.user
root@localhost 》select user,host from mysql.user;
+-----------+-----------+
| user | host |
+-----------+-----------+
| William | % |
| tzf | % |
| mysql.sys | localhost |
| root | localhost |
+-----------+-----------+
4 rows in set (0.00 sec)
#你可以看看简单的MariaDB www.linuxprobe.com/chapter-18.html你看看host里面有不有你的地址。
内容都差不多。另外我个人认为使用tar安装包,不要使用rmp安装。
用户名密码都正确,就是连不上mysql是怎么回事
通过wpa/wpa2进行保护了。
方法一:
设置-常规-WLAN-关闭WLAN功能,关闭之后再重新打开然后重新连接WIFI。
用手机连入WIFI,在初次连接成功之后手机中会保留一个由WIFI连接分配的网络IP地址,它会被应用到当前WIFI中,如果没有出现地址冲突,那么应该可以正常上网,但是如果出现IP冲突就可以用以上方法尝试解决。
方法二:
设置-常规-WLAN-选择连接异常的WIFI-点击右侧的WIFI信号图标-点取消保存-然后重新输入密码并重新连接,这样操作手机可以获得新的地址并正常连接。
方法三:
如果连接WIFI一直停留在验证的阶段无法正常连接,这里需要检查WIFI密码输入是否正确、WIFI密码是否有被更改或路由器的安全规则设置是否正确。
MyEclipse中连接MySQL出现的错误怎么解决呀,急求谢谢
在 MyEclipse 中连接 MySQL 时出现“Access denied for user ’root’@’localhost’ (using password: YES)”错误可能是由于多种原因造成的。
密码错误:您在 MyEclipse 中使用的 MySQL 用户名和密码与您在 MySQL 控制台中使用的用户名和密码可能不同。请确保您在 MyEclipse 中使用的用户名和密码是正确的。
MySQL 服务未启动:请确保 MySQL 服务已启动。
用户没有远程访问权限:如果您在 MyEclipse 中使用的是远程 MySQL 服务器,请确保用户具有远程访问权限。
建议您从上述几个方面入手,尝试解决这个问题。如果仍然无法解决,建议您参考 MySQL 官方文档或搜索网上的解决方案,或者向 MySQL 技术支持寻求帮助。
mysql怎么登录不了
1、首先打开电脑,然后点击左下角开始菜单按钮。
2、然后在开始菜单,下方搜索框中搜索cmd,在搜索结果中点击cmd命令窗口。
3、敲下回车键,打开cmd窗口,命令格式为mysql -u finley -p db_name如下图输入mysql -u root -p test命令,然后回车,意思是登录到test数据库。
4、提示输入密码,输入正确的密码,进入mysql命令行。
5、输入select database();确认是否为test数据库,如下图所示,test直接登录成功。
MySQL密码正确却无法本地登录怎么办
MySQL root密码正确,却怎么也无法从本地登录MySQL,提示
1 ERROR 1045 (28000): Access denied for user ’root’@’localhost’ (using password: YES)
这里后来经高人指点才发现mysql库中的user表缺少一个root指向host:localhost的数据项,只有一个root指向host:主机名的数据项,故怎么也无法利用root账户登录MySQL。
总结一点就是root账户缺失了访问localhost主机的账户信息,导致无法本地登录。
那有什么办法恢复root登录呢?
这里记录一下今天遇到的纠结事情:
首先kill掉MySQL进程然后在启动mysql的参数中加入
--skip-grant-tables
会发现这时无密码就可以登录mysql了。
当然我们还必须修复root账户丢失的数据项。
这里有两种解决方案:
第一种是因为root账户初始的时候有3条记录,包含root对应localhost,hostname,127.0.0.1三条账户数据,我们可以update host为其他两项中一项为localhost即可。
第二种是直接insert一条记录,host为localhost即可
总结一下:即使root的host包含了主机名,127.0.0.1那么依然是无法正常登录的,这里必须要有localhost的host才行。
如果上面办法还是无法正常登录我们可尝试另一种办法
在本地用mysql命令直接回车可以进入mysql,但是里面只有test和information_schema数据库,没有mysql等数据库,使用use mysql报如下错:
mysql》 use mysql
ERROR 1044 (42000): Access denied for user "@’localhost’ to database ’mysql’
意思是说没有指定user,没有权限访问数据库mysql。
那么用root登录呢,输入正确的密码报如下错:
# mysql -uroot -p123456
ERROR 1045 (28000): Access denied for user ’root’@’localhost’ (using password: YES)
密码正确的情况下,mysql数据库已经禁止了root用户在本地的登录权限了
mysql突然登录不了
1 进入cmd,停止mysql服务:Net stop mysql
若是停不掉:Ctrl+Alt+Del打开任务管理器,在详细信息里结束mysql.exe任务。
若服务名无效:来到MySQL的安装路径下bin,在命令行中输入mysqld --install;成功:出现Service successfully install代表你已经安装成功;
2 进入bin目录
mysqld -nt --skip-grant-tables
重新打开一个管理员命令提示符输入mysql进入重新改密码就OK了。
再次mysql -u root -p进入操作
mysql》update mysql.user set anthentication_string=password(‘你的密码’) where user=‘root’;
mysql》flush privileges;//刷新MySQL的系统权限
mysql》quit;
再次mysql -u root -p进入就可以操作了。

更多文章:
gcc编译器参数(深度linux的arm-linux-gnueabihf-gcc编译参数如何配)
2026年10月11日 19:30
asp是什么检查项目(医院血液检验项目RPR、TPPA、HIV-Ab各是什么意思)
2026年10月11日 10:20
汇编输出指令(用汇编语言循环指令在屏幕中间输出红底白字的“hello I am 720“)
2026年10月11日 07:20
本地搭建springboot项目(使用eclipse构建springboot项目)
2026年10月11日 06:20
java入门神器好用吗(java 7入门经典适合初学者自学用吗)
2026年10月11日 02:40
unix文件系统采用(Unix采用树形文件系统,其中“树形文件系统”什么意思)
2026年10月11日 00:50





