mariadb允许远程连接(centos7安装的mysql怎么远程连接)

本文目录
- centos7安装的mysql怎么远程连接
- mariadb 已经配置远程连接 但是还是不行
- mysql在centos上安装和远程连接
- mariadb远程连接错误115
- Navicat怎么连接MariaDB数据库
- navicat怎么连接到远程服务器
centos7安装的mysql怎么远程连接
1.安装MySQL
CentOS7中默认安装了MySQL系列的数据库,需要先卸载掉。
查看当前安装的mariadb包:
# rpm -qa | grep mariadb
将它们统统强制性卸载掉:
# rpm -e --nodeps mariadb-libs-5.5.35-3.el7.x86_64
***隐藏网址***
双击安装MySQL-server,MySQL-client和MySQL-devel三个安装包。
2. 启动MYSQL
#service mysql start
得到错误:ERROR!The server quit without updating PID file
我们这里主要是因为:selinux惹的祸,如果是centos系统,默认会开启selinux。解决方法是关闭它,打开/etc/selinux/config,把SELINUX=enforcing改为SELINUX=disabled后存盘退出重启机器。
然后再启动mysql就没问题了:
#service mysql start
查看MySQL运行状态:
# service mysql status
SUCCESS! MySQL running (2377)
3. 设置密码
安装之后root用户默认没有密码,通过命令设置密码。
# /usr/bin/mysqladmin -u root password ’passok’
然后设置root用户的远程访问权限
在mysql控制台执行
GRANT ALL PRIVILEGES ON *.* TO ’root’@’%’ IDENTIFIED BY ’MyPassword’ WITH GRANT OPTION;
FLUSH PRIVILEGES;
4.开启远程连接
需要安装iptables,
yum install -y iptables
然后系统的开放端口列表,增加3306端口,重启防火墙即可。
mariadb 已经配置远程连接 但是还是不行
首先配置允许访问的用户,采用授权的方式给用户权限
1
GRANT ALL PRIVILEGES ON *.* TO ’root’@’%’IDENTIFIED BY ’123456’ WITH GRANT OPTION;
说明:root是登陆数据库的用户,123456是登陆数据库的密码,*就是意味着任何来源任何主机反正就是权限很大的样子。
最后配置好权限之后不应该忘记刷新使之生效
1
flush privileges;
再次访问就可以了吧。
mysql在centos上安装和远程连接
首先要确保服务器上安装有MySQL,执行如下命令来检查是否安装了 MySQL(CentOS 7 上是 mariadb-server,CentOS 6 上是 mysql-server,这里以 CentOS 7 为例)
$ rpm -q mariadb-server
如果提示 package mariadb-server is not installed 则说明没有安装 MySQL,需要手动安装。如果出现 mariadb-server-xxx.xxx.xx.el7.x86_64 则说明已经安装。
安装 MySQL 的步骤为:
1.安装 MySQL 和 MySQL 客户端
$ sudo yum -y install mariadb mariadb-server
2.启动 MySQL
$ sudo systemctl start mariadb
3.设置开机启动
$ sudo systemctl enable mariadb
4.设置初始密码
$ sudo mysqladmin -u root password root
这时我们有两种方式来进行修改,这里只用了第一种,就直接将原来的 user=’root’ and host=’localhost’ 记录的host修改成%或指定的ip。
1.将host设置为%表示任何ip都能连接mysql
update user set host=’%’ where user=’root’ and host=’localhost’;
2.当然也可以将host指定为某个ip
update user set host=’*.*.*.*’ where user=’root’ and host=’localhost’;
这里将 . . . 换你实际的地址。
3.执行完以上语句,接着执行以下语句 ,刷新权限表,使配置生效
flush privileges;
1.检查服务器防火墙3306端口开放了吗,没开放需要去开放
2.检查一下云平台的安全组规则中是否开放了3306端口,如何配置阿里云,这里以阿里云为例( 阿里云添加安全组规则 )
mariadb远程连接错误115
由于远程连接被防火墙或其他网络设备阻止导致的。想问的是解决方法吧。
检查防火墙设置请确保您的防火墙允许通过MariaDB的端口进行连接。检查MariaDB的远程访问设置:请确保您已经允许MariaDB进行远程访问。检查网络连接:请确保您的网络连接正常。
问题仍然存在,请检查MariaDB的日志文件以获取更多信息,并尝试与MariaDB的支持团队联系以获取帮助。
Navicat怎么连接MariaDB数据库
方法一:用Navicat自带的SSH进行连接
1.首先我们在Navicat中新建连接
在用户名中填写远程数据库的登录用户名,密码框中填写MySQL登录密码
2.我们进入SSH连接配置
我们在主机名过IP地址一栏写上我们的远程服务器的IP
用户名为我们远程服务器的登录账户,密码就是服务器登录账户密码
3.连接测试
点击 左下方的连接测试,当弹出连接成功时,表示已经连接成功
注:使用该方法进行连接可能需要服务器安装SSH服务
方法二:直接使用IP进行连接
同样我们新建连接,不过我们这次在主机名中不填写localhost,而是直接填写我们远程服务器的IP
用户名仍然是我们数据库的登录账号,密码是数据库登录密码
我们点击连接测试时会显示2003错误
这是因为我们没有对数据库进行远程登录的授权,这时我们可以进入服务器后台,在MySQL命令行中输入以下命令
GRANT ALL PRIVILEGES ON *.* TO ’myuser’@’%’ IDENTIFIED BY ’mypassword’ WITH GRANT OPTION; myuser 改为你的数据库用户名 一般为root mypassword 改为数据库登录密码
这时我们继续进行连接测试,但是可能会同样出现错误,这时我们要对MySQL的配置文件进行修改
步骤:(1)cd /etc/mysql (2)vim my.cnf(如果该文件中没有下面的内容则打开/etc/mysql/mysql.conf.d/my.cnf)
navicat怎么连接到远程服务器
一、MySQL和MariaDB连接
可以连接到MySQL远程服务器,但基于安全原因,本机远程直接连接到MySQL服务器已禁用。因此,用户不能使用Navicat
Premium或其他类似MySQL管理应用程序直接连接到远程服务器,除非已配置用户权限。默认情况下MySQL
提供用户名为“root”,密码为空。
主机名或IP地址:数据库所在的主机名或服务器的IP地址。
端口:连接到数据库服务器的TCP/IP 端口。
用户名:连接到数据库服务器的用户名。
密码:连接到服务器的密码。
二、Oracle连接
Navicat支持两种Oracle服务器连接:
在Basic模式中,Navicat通过Oracle Call
Interface(OCI)连接到Oracle。OCI是一个应用程序界面,让程序开发人员使用第三代语言原有进程或函数呼叫来访问Oracle数据库及控制全部SQL语句运行的阶段。OCI是一个标准数据库访问的库和动态链接库形式检索函数。
在TNS模式中,Navicat使用在tnsnames.ora文件中的别名项目通过Oracle Call
Interface(OCI)连接到Oracle服务器。默认情况下,Oracle在安装时已创建一些用户帐号。管理帐号:SYS、SYSTEM、SYSMAN和DBSNMP。样本模式帐号:SCOTT、HR、OE、OC、PM、IX
和SH。
两种模式的连接类型:
Basic
主机名或IP地址:数据库所在的主机名或服务器的IP地址。
端口:连接到数据库服务器的TCP/IP端口。
服务名/SID:设置用户连接时用的服务名/SID。选择相应的选项按钮。
TNS
用户需要提供网路服务名。
用户名:连接到数据库服务器的用户名。
密码:连接到服务器的密码。
自动连接:勾选此选项,当程序启动时,Navicat会自动打开连接和显示登记的数据库。
三、PostgreSQL 连接
基于安全原因,本机远程直接连接到PostgreSQL服务器已禁用。因此,不能使用Navicat
Premium或其他类似的PostgreSQL管理应用程序直接连接到远程服务器。默认情况下,PostgreSQL只允许由使用TCP/IP连接的本机计算机连接。其他的机器将无法连接,除非修改在postgresql.conf文件中的listen_addresses,通过修改$PGDATA/pg_hba.conf文件启用基于主机的认证及重开服务器。默认情况下,PostgreSQL提供用户名为“postgres”,密码为空。
主机名或IP地址:数据库所在的主机名或服务器的IP地址。
端口:连接到数据库服务器的TCP/IP端口。
初始数据库:连接时,用户连接到的初始数据库。
用户名:连接到数据库服务器的用户名。
密码:连接到服务器的密码。
四、SQLite连接
可以选择SQLite数据库的“类型”和指定文件路径。
现有的数据库文件:连接到“数据库文件”的现有数据库。
新建SQLite 3:在“数据库文件”创建新的“SQLite 3”数据库。
新建SQLite 2:在“数据库文件”创建新的“SQLite 2”数据库。
数据库文件:指定初始数据库文件。如果HTTP通道打开,需要输入数据库的绝对文件路径。
五、SQL Server 连接
主机名或IP地址:数据库所在的主机名或服务器的IP地址。
使用两种方式来验证连接到SQL Server数据库:SQL Server验证和Windows 验证
SQL Server验证:SQL Server验证使用登录记录来验证连接。每次用户连接,都必须提供他们的服务器登录的用户名和密码。
Windows验证:当一个用户通过一个视窗用户帐号连接,SQL Server会使用操作系统中Windows主要代符来验证帐号名及密码。这意味着用户身份是由Windows确认。SQL Server不会要求输入密码,并且不执行身份验证。

本文相关文章:
dede一键安装包(centos7在虚拟机中怎么搭建dedecms环境)
2026年9月18日 06:10
gradient clipping(loss出现Nan的解决办法(梯度爆炸))
2026年8月9日 04:10
免费photoshop下载(Photoshop那里有免费的下载,)
2026年7月14日 22:50
更多文章:
gcc编译器参数(深度linux的arm-linux-gnueabihf-gcc编译参数如何配)
2026年10月11日 19:30
asp是什么检查项目(医院血液检验项目RPR、TPPA、HIV-Ab各是什么意思)
2026年10月11日 10:20
汇编输出指令(用汇编语言循环指令在屏幕中间输出红底白字的“hello I am 720“)
2026年10月11日 07:20
本地搭建springboot项目(使用eclipse构建springboot项目)
2026年10月11日 06:20
java入门神器好用吗(java 7入门经典适合初学者自学用吗)
2026年10月11日 02:40
unix文件系统采用(Unix采用树形文件系统,其中“树形文件系统”什么意思)
2026年10月11日 00:50



