msdtc安装(MSDTC服务已启动,但安装消息队列时仍报错0x42c)

本文目录
MSDTC服务已启动,但安装消息队列时仍报错0x42c
解决办法:重新安装msdtc服务
开始--运行--cmd
net stop msdtc
msdtc -uninstall
msdtc - install
net start msdtc
msdtc服务是什么
msdtc.exe是微软分布式传输协调程序。该进程调用系统Microsoft Personal Web Server和Microsoft SQL Server。该服务用于管理多个服务器。
MSDTC设置方法 打开“管理工具――组件服务”,以此打开“组件服务――计算机”,在“我的电脑”上点击右键。在MSDTC选项卡中,点击“安全配置”按钮。 在安全配置窗口中做如下设置: 选中“网络DTC访问” 在客户端管理中选中“允许远程客户端”“允许远程管理” 在事务管理通讯中选“允许入站”“允许出站”“不要求进行验证” 保证DTC登陆账户为:NT Authority\NetworkService 修复办法 首先进入组件服务,查看组件服务/计算机/我的电脑/COM+应用程序,结果报错“COM+ 无法与 Microsoft 分布式事务协调程序交谈”,无法查看里面的对象。 2、进入事件查看器,发现msdtc服务没有正常启动。 3、删除注册表中的键: ? HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSDTC ? HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSDTC ? HKEY_CLASSES_ROOT\CID 这些都会了,但是后面msdtc的停止\卸载\安装在哪里都不知道了,请指点下列步骤的具体操作方式4、停止MSDTC服务:net stop msdtc 5、卸载MSDTC服务:msdtc -uninstall 6、重新安装MSDTC服务:msdtc -install 7、确认在事件查看器中msdtc服务已经正常启动 9、同步IIS metabase中IWAM_MYSERVER的密码,在CMD中:c:\inetput\adminscripts》adsutil set w3svc/wamuserpass "yourpassword" 10、同步COM+应用程序所用的IWAM_MYSERVER密码,在CMD中:c:\inetput\adminscripts》cscript synciwam.vbs -v
msdtc服务启动不了,百度都说删掉msdtc注册表然后重装,我去,重装根本没用现在服务列表都没有dtc了
你把该服务停止,然后删除,相应注册表也删掉,然后重新安装,还有该服务依存Microsoft Personal Web Server和Microsoft SQL Server这两个服务,因此也必须得运行。

更多文章:
gcc编译器参数(深度linux的arm-linux-gnueabihf-gcc编译参数如何配)
2026年10月11日 19:30
asp是什么检查项目(医院血液检验项目RPR、TPPA、HIV-Ab各是什么意思)
2026年10月11日 10:20
汇编输出指令(用汇编语言循环指令在屏幕中间输出红底白字的“hello I am 720“)
2026年10月11日 07:20
本地搭建springboot项目(使用eclipse构建springboot项目)
2026年10月11日 06:20
java入门神器好用吗(java 7入门经典适合初学者自学用吗)
2026年10月11日 02:40
unix文件系统采用(Unix采用树形文件系统,其中“树形文件系统”什么意思)
2026年10月11日 00:50





